3

You may know that Joomla 2.5 is EOL with 2.5.28 that will be released shortly.

There is a marketing campain planed for this, see https://groups.google.com/forum/#!topic/joomla-dev-cms/f7Waw1KlFdE

So the question is how could we help communicate this.

For example

  • add a text to all Answers for 2.5 that this version is End Of Life.
  • add a "EOL" tag to each question?
  • do nothing...
| |
  • This question and the answers below could equally apply to Joomla 1.5 and even Joomla 1.0. I think it's definitely worthwhile adding a note to answers when appropriate as Lodder suggests but this is probably a manual process as it may not apply in every case e.g. when the question contains, "I know I should be updating to Joomla 3.x but can't yet because of...". – Neil Robertson Dec 12 '14 at 12:41
  • You are right this is also valid for older versions. If we get a con sens, I'm sure that mods/users will add this disclaimer to all new 2.5 and older questions/answers. – Harald Leithner Dec 13 '14 at 12:24
3

I personally think we should simply add a small disclaimer/notice to our answers for Joomla 2.5 questions, for example:

Disclaimer: Please note that Joomla 2.5 has reached End of Life (EOL), therefore is not longer officially supported. This does not mean your site will stop working, however, highly we suggest you start migrating to Joomla 3.x.

| |
3

The reality is that there is that there is still a large user base using Joomla 2.5. We cannot change that. Even a couple of projects that I have worked at (some with origins in 1.5) are going to stick with 2.5 for the moment, mostly because of the financial aspect.

I think the need for support will naturally fade away, as it did with Joomla 1.5. It just requires time. We would all like to have all websites overnight jumping to 3.x, but it is not always that easy. So we can help propagate, but we cannot chance the fact itself.

Regarding the information aspect. The last update to 2.5.28 will bring with it a new plugin which will cast a clear message that this version has reached EOL.

Adding text to all existing questions might be a fair approach. But it can be time consuming and somebody needs to commit on the long run to maintain this message. At the time of this writing, there are around 200 questions tagged with jooma-2.5. It is some work to edit so many questions.

Considering the above mentioned aspects, I propose as follows:

  • Update the joomla-2.5 tag to reflect that Joomla 2.5 has reached EOL.
  • Do nothing else.
| |
  • I didn't mean to edit all old questions, that makes no sense. I mean it only for new answers and maybe for a limited time only. – Harald Leithner Dec 10 '14 at 12:59
  • Ok, I understand now. – Valentin Despa Dec 10 '14 at 13:22
0

Do nothing. Reasons listed below.

  • Writing duplicated content is not answering the question at hand and is wasting valuable resources that could be used elsewhere.
  • It's annoying if you have no choice but to use an old version and get reminded every single time you ask a question.
  • I'd like to think that Joomla users are not fools. If they use this site regularly, they are bound to see questions for higher versions of Joomla. This will become increasingly so. If they can't put 2 and 2 together.....
  • It isn't our job to remind people about the latest version. As mentioned, there is already a campaign. If you feel that the user asking the question isn't aware of the most recent version of Joomla then add a comment.
| |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .